VPN beállítása

A VPN vagyis virtuális magánhálózat azt a célt szolgálja, hogy távolról is a saját hálózatunk erőforrásait (myIO server, Home assistant, nyomtatók, NAS, videórögzítő, stb.) használhassuk. Ilyenkor a routerünk interneten elérhető publikus címén tudjuk vele felvenni a kapcsolatot, és a magánhálózatot a beállításoknak megfelelően kialakítani vele. Többféle megoldás létezik, cikkünkben az L2TP-IPsec alapbeállítását írjuk le. A megoldás használata közben az IPsec beállításával titkosított formában folyik a kommunikáció a kliens és a router között, ezért ez elég nagy terhelést eredményez a routernek, ha nincs benne kimondottan ezt a titkosítást végrő hardveres támogatás.

mikrotik router wifi
  • Lépjünk be a Mikrotik eszközünkbe winboxal vagy a web config menüjébe
  • Bal oldali menüben válasszuk az 'PPP' menüpontot
  • Válasszuk a 'Secrets' nevü fület
  • Kattintsunk a '+', vagy az 'Add New' gombra
  • A New PPP Secret ablakban a következőket állítsuk be
  • a 'Name:' pontnál írjunk be egy felhasználónevet amit a kapcsolódáskor használni akarunk, pl,: ppp1
  • a 'Password:' pontnál írjunk be egy jelszót amit a kapcsolódáskor használni akarunk, pl,: 12345
  • 'Local Address:'-nél írjuk be a routerünk belsőhálózati IP címét, pl.: 192.168.1.1
  • 'Remote Address:'-nél írjuk be a csatlakozó kliensnek kiosztandó IP címet, pl.: 192.168.1.251
  • Bal oldali menüben válasszuk az 'PPP' menüpontot
  • Válasszuk a 'Interface' nevü fület
  • Kattintsunk a 'L2TP Server' gombra
  • Az L2TP Server ablakban a következőket állítsuk be
  • 'Enabled' elé tegyük be a pipát
  • az 'Use IPsec:' pontnál válasszuk a 'required' lehetőséget
  • 'IPsec Secret:'-nél írjuk be az IPsec-nél használni kívánt kulcsot, pl.: 12345
  • Bal oldali menüben válasszuk az 'IP' menüpontot alatti 'Firewall' lehetőséget
  • Válasszuk a 'Filter Rules' nevü fület
  • Kattintsunk a '+', vagy az 'Add New' gombra
  • A képen látható, hogy a cikk írásához használt routerben nem találhatóak tűzfal szabályok. De egy internetről elérhető élesben használt routerben ez nem lehet így, ezért is írom le, hogyan engedjük át a tűzfalon a magánhálózatunkat.
  • A New Firewall Rule ablak General fülén a következőket állítsuk be
  • 'Chain:' lehetőségnél válasszuk a 'input' -ot
  • 'Protocol:' lehetőségnél válasszuk az 'udp' -t
  • 'Dst. Port:' -nál vesszővel elválasztva soroljuk fel a szükséges portokat jelenleg az 500, 1701 és 4500
  • Lépjünk át az 'Action' fülre
  • Az 'Action:' lehetőségnél válasszuk ki az 'accept' -et
  • 'OK' gombra klikkelve alkalmazzuk az új tűzfal szabályt
  • Ezt követően az előző szabály létrehozásához hasonlóan hozzunk létre egy másikat is, de itt a 'Protocol' résznél válasszuk az 'ipsec-esp' lehetőséget és ne adjunk meg 'Dst. Port' -okat.
  • Ezen lépések elvégzését követően már tudunk kapcsolódni routerünkhöz VPN-en keresztül.
  • Ugyanezt az eredményt érjük el, ha a bal oldali menüben a 'New Terminal'-t választjuk és kiadjuk a következő parancsokat:
  • /ppp secret add name=ppp1 password=12345 local-address=192.168.9.1 remote-addr ess=192.168.9.251
  • /interface l2tp-server server set enabled=yes use-ipsec=required ipsec-secret= 12345
  • /ip firewall filter add chain=input protocol=udp dst-port=500,1701,4500 action=accept
  • /ip firewall filter add chain=input protocol=ipsec-esp action=accept
Shopping Basket